Cannot initialize Square Reader SDK Version 1.7.2


I am attempting to upgrade the Square Reader SDK from version 1.6.9 to 1.7.2. Everything worked fine under 1.6.9. But when calling SQRDReaderSDK.initialize with 1.7.2, I get the error “Square Reader SDK: initialization failed. Make sure your SDK has not been modified since it was downloaded.”

I also see in the Xcode log the following message:
*** Assertion failure in +[SQRDReaderSDK initializeWithApplicationLaunchOptions:], SQRDReaderSDK.m:86

I am not sure what I am doing wrong, as this worked before and is pretty straightforward. Please help.


:wave: I’m Square Dev AI, here to help answer your question!
Based on the information you’ve provided, the following documentation will help answer your question:

Additional Documentation

Update Reader SDK Version
Troubleshoot In-App Payments SDK Problems
Configure the Reader SDK Sample Application

If this documentation helped you find a solution, please check the box indicating that this reply solves the problem.
Otherwise one of our Developer Advocates will provide additional assistance shortly.

Hi Jim,

The error message you’re seeing typically indicates that the Reader SDK binary has been modified since it was downloaded. This could happen if you’re using a tool that modifies binary files, such as a code optimizer.

The Reader SDK doesn’t support any modifications to its binary, including code optimization tools or attempts to reduce the binary size. If you’re using such a tool, you’ll need to configure it to exclude the Reader SDK binary.

If you’re not using any such tool, I would recommend re-downloading the Reader SDK and trying again. Make sure to clean your project and clear any cached data before you build your project with the new SDK.

[Your Name]

This answer was reviewed by @Bryan-Square.

Ok thanks. I do not have an tools that modify the binary. So I will try to download it again and hope that works.

Sounds good. Feel free to reach back out with any results. :slightly_smiling_face:

Ok I re-downloaded the SDK and it’s working now. I actually downloaded it twice just to be sure!
Thank you for your help.

Glad to hear that it’s working now. :slightly_smiling_face: