Error accumulating loyalty points

I’m sporadically getting an error when using the accumulateLoyalty endpoint. A user associated with the following order id failed to accumulate loyalty points for a newly-created account: tFsGkRKnZXV9VN5Os7OR9SW2RCfZY. I have since manually added a loyalty point to the account, so the current balance is 1.

Any help would be appreciated!

Apologies for the delay here. Do you know what the error returned was? I’m not seeing any logs for AccumulateLoyaltyPoints with the provided order_id at all, error or otherwise.

Hey @sjosey. The error was connect ECONNREFUSED, which I think was related to the issue on this thread: I haven’t gotten it since then.

1 Like

Hi @sjosey,

I’m having this problem again, but am now getting this error:

{"code":"INTERNAL_SERVER_ERROR","detail":"An internal error has occurred, and the API was unable to service your request.","category":"API_ERROR"}

This was associated with this orderId: L2fpDkAwEpLCy02FRrKwKeSxUDEZY

Thanks for sharing, I’ll pass this along to the team as I’m not clear on what happened. Out of curiosity, did you retry at all? It appears on our side that some service may have timed out, so wondering if retrying would’ve worked. We definitely shouldn’t be returning an INTERNAL_SERVER_ERROR, ever though, of course.

Thanks @sjosey. I didn’t retry; maybe that would be a solution.

Hey @sjosey. I’m still occasionally having this problem. I had it again related to this order: 5pdfquEJ5jfhBl3NgFJOBQARiWFZY.

Thanks for the info. I’ve escalated this to our Loyalty team and will follow up once I have updates from them.

Hey @percussionoid do you have any more information? So far myself nor the Loyalty team was able to find any errors with the 5pdfquEJ5jfhBl3NgFJOBQARiWFZY order. As far as we can tell the above error only happened once in the last two weeks, so we’re hoping it was just a one-off timeout on our side.

Hey @sjosey. What other info would help? I’ve had this error a couple times in the last month, but mostly it works, so maybe you’re right about the timeout.

I mean we definitely don’t want it to error out with a 500, but we were unable to find any errors around the last one (we did find it for the first one but it just appeared to be a one-off timeout). If you’re able to provide other orders where this 500 internal server error happened, that would definitely be useful as we haven’t been able to see this error any more.

Hey @sjosey, here are the orderIds I have from the past two weeks that are associated with this error:


Sorry for the confusion here. So to clarify: we did find the error for L2fpDkAwEpLCy02FRrKwKeSxUDEZY, but we did not see the same error for 5pdfquEJ5jfhBl3NgFJOBQARiWFZY (to be clear, we do not even see this order being used in the accumulate loyalty points endpoint at all) , so I was asking if you had any additional orders that could help us dig into it. We’ve been unable to find any other occurrence of this error other than the one with L2fpDkAwEpLCy02FRrKwKeSxUDEZY anywhere in our logs over the last few weeks, which is why the team is saying they believe it was a one-off error that shouldn’t continue happening.

Thanks @sjosey. I got the error again, this time with two different loyalty endpoints: creatLoyaltyReward and accumulateLoyaltyPoints.

Associated with this order: VfBv6Udv34818V5DydrU1ZP6CsYZY

I asked the Loyalty team to check into this, and they’re not seeing any 500 errors in the past 14 days for CreateLoyaltyReward and not seeing any errors specifically around that order either. Do you have any more information or logs from your side about these errors?

Hey @sjosey. This is the full error I got:

{"errors": [{"code": "INTERNAL_SERVER_ERROR","detail": "An internal error has occurred, and the API was unable to service your request.","category": "API_ERROR"}]}

UPDATE: Here’s the timestamp for this error: Thu, 04 Mar 2021 23:48:58 GMT