/v2/terminals/checkouts Requiring Signature?

We’re using the /v2/terminals/checkouts API to integrate Square’s Terminals in with our existing POS system.

We’ve found that ~half the time, the cardholder is asked to give a signature. I’ve not been able to find anything in the API/settings to be able to turn this off (though the configuration option is obvious when the terminal is in normal POS mode). We haven’t been able to distinguish any pattern to it so far (debit/credit/card present/manual entry, seems to be happening across the board).

The closest setting I can find is skip_receipt_screen under the DeviceCheckoutOptions, but that doesn’t really directly address signatures.

Besides, AFAIK, Disable Signatures for Payments | Square Support Center - US says that you guys weren’t asking for signatures period after April of this year.

Am I missing something?

:wave: If skip_receipt_screen is to false your customer shouldn’t be asked for a signature. If it is set to false and your customer is asked for a signature do you have an example checkout_id? :slightly_smiling_face:

Ahh, okay. We haven’t set skip_reciept_screen to false yet (we’ve left it on default). I’ll give that a go and circle back.

Thanks for the quick reply!

@Bryan-Square On second thought, the default for skip_reciept_screen is already false. Do you mean to set it to true?

Got some clarity from the team. The skip_receipt_screen only controls whether Square shows the screen that asks how you want a receipt. It has nothing to do with showing the signature or not. We unfortunately don’t have a parameter to show/hide signature screen. The workaround to stop showing it is to log out of the Terminal API mode, log-in to the regular square account using user name and password, and disable signature there. When you log back in to Terminal API, signature should be disabled. :slightly_smiling_face:

Ok, I’ll let you know what we find!

All but one of the terminals (4 out of the 5) already had signatures turned off when I checked, but perhaps going through those steps saved the setting in the right place this time around.

:thinking: Hmm, that is odd. Happy to hear that it’s now working as expected.

Circling back on this - things are working correctly now, and the Terminals aren’t requesting signatures anymore. The odd bit, though, was that 4 out of the 5 Terminals I “fixed” already had signatures turned off when I logged in. I toggled it on/then off again just to be sure, but I wanted to note that in case it makes a difference.

I’m going to definitely share that with the team. :slightly_smiling_face: