Hello Developers

I have a form on my WordPress built website

in which I am trying to use Square to recieve payment.

However, when I try to pay it pops a “REQUEST NOT AUTHORIZED” error as I input the following test card details.

Test Credentials :
Card Number : {{redacted}}
Card CVV : 111
Card Expiration : 08/2024
Card Postal Code : 44101

On my backend section on my website in Square, I used the following test credentials.

Location ID :- LN0ZPJ72GAFD3

Please help !!!

Hi @Joseph welcome to the forums!

First, it looks like you just shared a real card rather than a test value, so I strongly urge you to contact your bank and have the number changed immediately as this has been public for some time, and possibly cached.

Further more, I’m not seeing any logs for that particular sandbox application id around payments (I see one or two requests about ListLocations and that’s it). Can you share exactly what you’re calling and how you’re setting the credentials (with the credentials redacted)?

Thank You for the Response Stephen

It wasn’t a real card, it is a test value from

I would not put out my real card info publicy. Thanks for the concern.

Okay, this is it. On my WordPress Website, I created a Form Using Caldera Forms and I am trying to use Square which is a third party plugin on Caldera to recieve payment on the website.

This is the settings for the test credentials on the backend and how I am setting it.

Test Application ID :- sandbox-sq0idb-SKf5r91WoDy4dcCkbccXsA

Test Token :- Is it safe to put my Token here?

Test Location ID :- LN0ZPJ72GAFD3

Not sure where they’re getting the test card value, it shouldn’t work on Square to be clear (our sandbox only works with specific cards, which I shared in the above link - other cards should automatically fail in sandbox including real cards). I saw the card being used tons of times in production, which is why I assumed it was a real card.

As I mentioned earlier, I looked up that application id already and there’s no payment endpoints being hit, so something is going wrong. You may need to reach out to API Experts support team, as they made this plugin, not Square, and since I’m not seeing anything in our logs, it’s not making it to our server, or something else is going wrong. It’s also not OK to share the access token just for future reference (those are secret and should not be shared with anyone).

Okay, I tried the test card data from the link you shared just now and it’s the same error.

I have reached out to API Experts and I look forward to their favorable solutions.

Thank You