Sandbox Catalog Api list in explorer is displaying empty

I am trying to access sandbox Default Account items that were created for purchase from the Catalog List API. However, the list is empty when I make the API call from the explorer with the Default Account access token in Sandbox mode. I am seeing production items returned from the API explorer when I switch modes. Is there some kind of documentation/step I am missing in marking sandbox items for display in the catalog?

I am able to access the items from an empty search catalog items request.

With our sandbox items in the production catalog won’t be available in the sandbox catalog. You’ll need to create items in sandbox to populate the catalog. :slightly_smiling_face:

Sounds good, that was already done, I have created separate items in the sandbox account, these newly created items though are not showing up when I run the “List Catalog” request. They are however showing up when I run the “Search Catalog Items” request. I imagine I did something wrong when configuring these sandbox items that is preventing them from showing up in the catalog. Any insight into that and how I can get these items to display when I hit the “List Catalog” endpoint?

What are the catalog_object_ids and what’s the application ID. Also please never share the access token. They are secret. I’d recommend recycling the one you posted here. :slightly_smiling_face:

Ok it is recycled, sandbox-sq0idb-EpaF2Kv7eJScMz6Lrwa7qg, I dont see a catalog_object_id on the items that are returned from the “search catalog items” response. “id”: “BNWPACIGYFXN5RZCK46ODWTU”. Here is an id of one of the items.

I just called ListCatalog for that item and it was in the results. :slightly_smiling_face:

In the first image the explorer is calling the list catalog endpoint using the “sandbox-sq0idb-EpaF2Kv7eJScMz6Lrwa7qg” Default Test Account. No results are returned, this is unexpected since I have created 5 products from the seller sandbox dashboard.
In the second image I am calling the Search Catalog Item endpoint with the same sandbox access token and my items are appearing as expected.
Question is why am I getting no items from the ListCatalog call but I am getting items from the SearchCatalog call. I would expect the search catalog call to always have the same number of items or less but never more. Is there something that I am not understanding?

You can disregard. The wrong catalog version is autofilled by the explorer. removing that provides the expected results

Glad to hear you figured it out. :slightly_smiling_face: