Checkout API "preview link" not working

hey all,

Ive been working on building out a checkout api flow for my application, but some reason i cant seem to “Preview Link” in sandbox mode. Chrome keeps giving me the following error: sent an invalid response.

i have also tried this by creating a basic checkout API link using the API explorer.


What’s the link that your getting this error with or the CreatePaymentLink request that was used to generate the link? :slightly_smiling_face:

actually i figured it out with some help from Square ECOM team. they suggested trying to open the link via 5G or some other internet service. that seemed to work. so they suggested it might be my ISP.

believe it or not, it was my ISPs DNS servers. once i switched by DNS servers (on my router) to Google DNS, the link worked perfectly.

This information really should be added to Squares ECOMs teams guidelines, since this would be helpful, since i think a lot of people don’t natively think about their DNSs

Glad to hear that worked. Thanks for sharing your findings. :slightly_smiling_face: