Batch-delete endpoint .... Think I messed up

In Sandbox…my code ran a little crazy… (its now fixed)
Background: Project needs to have a product created, stock assigned an option flat rate shipping created. It needs to be accessible for short time, then when the “sale” is over, the product gets deleted.
Got it handled. no issue.

however, accidentally created couple thousand of the same items without deleting them while testing.

so, in an attempt to remove the items, I exported the library, and attempted to batch-delete the tokens listed in exported csv in sets of 200.

got responses back that the object_id’s had been deleted.

when looking at the items list again, for each item, all parent objects had been removed, however a line item with the value “variable” under price remained.

again exported library… checked to see that type of each id was denoted as “variable” in csv.
attempted to batch delete ids from export…
recieved 200 with deleted id’s
again, all line items remained, with new ids…

I have sorted out the code, which now works fine, and would be fine with simply deleting the current library all together. I tried to import a single line to the library and replace the existing library, that as well is not working…
any ideas?

Hi @Horticode
If you are looking for a fresh start in sandbox, you could create a new test account in Developer Dashboard. Then you would only be concerned with importing the corrected catalog. But you will lose all the history of previous orders.

I am not sure I understand where the original sandbox account’s catalog is at? What was is the next thing you need to do to fix it’s catalog? You cannot undelete or otherwise modify a deleted CatalogObject instance. Attempting to do so gets you a 400 response indicating an invalid operation to update a non-existent object.

thanks @Lance-Square,
yep… tried that already…
nothing will register to items library in the new test account…
be it, api created, or UI created…lol
so, I was confident the code was fixed, so tested on main account which worked… but now i have a different question… so new post…
I will flag you on that one incase you know of a solution!