All terminals report being offline all day

So we had an issue today with our app. All kiosks (roughly 12 of them) stopped working at the same time, just after noon. They won’t attempt to issue checkout requests because the terminal is unavailable. Ok, odd. The terminals seem fine, and the square status page says everything honky dory.

After some goofing around, we fired up an older version that never cares what the device is up to, it just calls the apis. That app worked. We were pinging the device on the newer app using the terminal action api, so I scrapped that and rewrote it to just ask the getDevice endpoint for the device. I have a dev terminal at my desk, as I worked on removing all ‘pinging’ code, I was using this dev unit. It always returned “OFFLINE”. I figured it was because it wasn’t “paired” with my dev machine. I implemented the changes an built a new test version and tried it out on one of our kiosks. Nope. Same issue.

The app reports that the terminal is unavailable. Reboot terminal. Same again. Oh well, I’m not sure if it’s me or what but I give up trying to figure out if there is a device at the other end. I’m done for the day. I’ll come back tomorrow and rip out all the stuff that tries to figure out if we are sending calls out to the void.

Let me know if I’m crazy. See you in the morning.

Edit: We have some terminals in “manual” mode. Were you login and use the pos software on the device. Those have been fine all day.

What’s your application ID and a device_code your seeing this behavior with? :slightly_smiling_face:

App id: sq0idp-e40Zku_jq6CCmmS4eQx1TA
Device ID: 226CS149B1002723

App id: sq0idp-e40Zku_jq6CCmmS4eQx1TA
Device ID: 226CS149B1002723

Sorry, I think I replied the wrong way initially.

Were not seeing anything out of the ordinary with the device on our end. Is the device up to date? :slightly_smiling_face:

It was last time I checked. I removed all device checks for the moment. I’ll come back and report when/if I reintroduce them.

Sounds good. Hopefully an update resolved this. :slightly_smiling_face:

I’m experiencing the same issue; despite the Terminal indicating online and being able to process payments, the Get device API consistently returns Offline.

Yup. I’m working on a bunch of other stuff so I haven’t been able to look to far into it. I’m avoiding this endpoint for the time being, it is still in beta after all.

Okay, also please note Devices API doesn’t support real-time heartbeat checks for a device. A device has a 15 minute interval to return an up-to-date status. If the device hasn’t returned a status update after approximately 30 minutes, then the device is likely to be offline. :slightly_smiling_face: