Which version of the square api is compatible for the odoo 17 enterprise?

i want to know which version of the square api is compatible with the odoo17 enterprise?

Have you reached out to Odoo to see what versions are supported? The would be the ones that know since the integration is managed by them. :slightly_smiling_face:

To find out which version of the Square API is compatible with Odoo 17 Enterprise, it’s recommended to reach out directly to Odoo, as they manage the integration and would have the most accurate information regarding compatibility.