When using Device Code generated in Production, Square Terminal gets stuck at Powered by Square

When i use a Device Code generated using Create Device Code in Production, the Square Terminal accepts the Device Code but after the “loading Square Terminal” it gets stuck at “Powered by Square”. I tried hard resetting the Terminal and use a different device code generated in Production a few times but still got the same thing, what am I missing? Thanks!

:wave: With the Terminal API that is the screen that is supposed to show when logging in with a device code generated by the Devices API. Now you can use the device_id that was created and call CreateTerminalCheckout to request a payment from the Terminal. :slightly_smiling_face:

Thanks for your message. I tried doing that by using the device ID generated with Create Device Code, but I keep getting invalid device ID message.

Are you using the field that is titled device_id? I know I made the mistake of using the id instead of the device_id when the Terminal API first launched. :slightly_smiling_face: Here is an example response from the Devices API with the device_id of 952CS108A6002588.

            "id": "09FGKH6E0Q84S",
            "name": "Counter 1",
            "code": "YQFEBD",
            "device_id": "952CS108A6002588",
            "product_type": "TERMINAL_API",
            "location_id": "3Z4V4WHQK64X9",
            "created_at": "2020-05-01T03:48:28.000Z",
            "status": "PAIRED",
            "status_changed_at": "2020-05-01T03:48:49.000Z",
            "paired_at": "2020-05-01T03:48:49.000Z"
1 Like

thanks my issue has been fixed.