Terminal - Crashing on CreateTerminalCheckout


Received Terminal today.

Created a Device Code:

POST https://connect.squareup.com/v2/devices/codes
  "device_code": {
    "product_type": "TERMINAL_API",
    "location_id": "*************",
    "name": "Foobar Inc"

Used the device code to sign in to the Terminal. Got a device.code.paired webhook.

The terminal shows the “Powered by Square” screen.

Made a checkout request for the terminal:

POST https://connect.squareup.com/v2/terminals/checkouts \
  "checkout": {
    "amount_money": {
      "amount": 1,
      "currency": "GBP"
    "device_options": {
      "device_id": "****************"
    "payment_type": "CARD_PRESENT"

The screen goes blank for a moment, then the Square logo scrolls in from the right (1s), then the screen goes white with a loading spinner and the text “Loading Square terminal” with a percentage. Within about 1.5 seconds, it’s at 100% and we’re back to square 1 (showing the “Powered by Square” screen.

I’ve tried a CreateTerminalAction request (with a confirmation screen), and this worked fine.

I’ve also tried the terminal in the non-connect mode (signing in with a Master account rather than via a Device Code), and was able to take a £1 keyed-in payment via inserting a Debit Card. Contactless would not work; I tried my phone (Google Pay), and various physical debit cards. The only successful payment was via an inserted Chip + Pin card. Any tips there?

Many thanks.

Are you running into the minimum transaction value? It’s £1 in the UK, so you would need to send “amount”: 100 instead of “amount”: 1

Changing the amount to 100 makes no difference; the terminal still appears to crash when it receives the request. Thanks though, that would have been the next problem :laughing:

Have you restarted the Terminal? :slightly_smiling_face:

Several times unfortunately :frowning:

I did say it needed an update - when I pressed “Ok”, it didn’t seem to do anything. Version shows as 5.37.0075. Do you know if that’s latest?

Okay, if you tried all the general troubleshooting steps the next step would be to do a factory reset. :slightly_smiling_face:

Thanks. Whilst looking for the Reset option, I found Settings > Hardware > General > About, where there was an option to install an update. OS Version now showing as 5.41.0088.

And, the request worked! Additionally, I was able to make a contactless payment.

Looks like OS 5.37.0075 is just very, very broken. All good now, I’ll get on with building something cool :wink:

Thanks for your help.