Sandbox Testing with OpenCart


I’ve just signed up to Square and trying to integrate it with OpenCart. I configured OpenCart to use a sandbox account and everything connected OK.

I done a test transaction, and it went through as expected - excellent!

However, I try to do another one, but when i click on “Continue” in Step 5 of the Checkout process and it now just sits there and the button just says “Loading… Please Wait…”

I’ve tried using a new developer API to see if that is a problem, but it still doesn’t work.

I’m using OpenCart, Square extension version 3.3.4 and using Chrome. Is there a ecommerce package which Square recommends, as it seems OpenCart doesn’t integrate too well with Square and i don’t want to spend a long time creating a shop which may have further problems down the road!

Any help would be much appreciated.

:wave: Have you reached out to OpenCart about this? Although Square integrates with OpenCart to process payments, all API functions are operated and managed by OpenCart directly. For help with OpenCart specific questions, you’ll need to contact their Support Team.

If for some reason they are not able to help you, please contact us with your OpenCart ticket/case number, and we’ll see what we can do from our side. :slightly_smiling_face:


I’ve raised a ticket with Opencart as requested and see what their response is before I decide to find another ecommerce package or payment processor - or both! :rofl:

Top notch support is key with this sort of thing :+1:

Great, please feel free to reach out if you have any additional questions. :slightly_smiling_face:

Well. It’s now been 4 days since I’ve heard back from iSenseLabs after they requested a login account to see what was going on. You can’t contact them to request an update otherwise the ticket or the 48 hour response time resets.

I will be looking at a different ecommerce solution (WooCommerce) or an integrated solution such as Ecwid. It’s a shame because OpenCart has all the features you need to get going, but with being Open Source, lacks support.

Best to find these things out now because if this was an established, finished ecommerce solution the company would be losing money – you get what you pay for! L

I have received a reply back from iSenseLabs. The issue was caused by having a " ’ " in the test home address I was using (999 Let’s Be Avenue). Once the ’ was removed (999 Lets Be Avenue), the test payment went through as expected.

Not sure if this is a ‘bug’ which needs to be fixed by iSenseLabs or i was just unlucky to find it.

Thought i would let you know in case anyone else was having this type of issue, and didn’t want anyone else to feel frustrated when you have the same problem, but a forum post is left unanswered!

Glad to hear that you figured it out. Thanks for sharing the solution. :slightly_smiling_face: