Prestashop Integration Issues with Webhooks

Hi guys,

Really hoping someone can help me. I have been trying to get my square account integrated with my Prestashop via the SquareOfficial module. I have got as far as the webhooks set up using the developer area of Square but they just wont run. The instructions give the link to use as the webhook endpoint which I have set up and saved however, when I run a test event they keep returning 403 forbidden.

I am really close to giving up with it now as have tried to sort it multiple times with support and its still not working.

If anyone can help or point me in the right direction I would really really appreciate it.


:wave: Is this in production or sandbox. Also do you have a link to the setup instructions? :slightly_smiling_face:

Hi Bryan,

Thanks for responding and it is in production mode and yup I have the instructions and followed them as well as I can. I honestly dont know if its me that is getting it wrong (though it doesnt read that difficult) or whether something is wrong with the endpoint link maybe.

I have been sent multiple versions of the module to use following fixes and things but really just want to get the basics working to manage the stock across in store and online :slight_smile:


I took a look at the account and the webhooks are sending correctly. It looks like its not being received correctly cause there’s a lot of retries. Have you reached out to Prestashop about this? :slightly_smiling_face:

I have reached out to square and the app developers at the moment not specfically Prestashop though.

If they are sending correctly but not being received it must be on the module side that its not working. Could that be to do with the endpoint link?

It’s possible and that’s why their engineers will need to look into this. :slightly_smiling_face: