iOS 15 issue with Card Reader connection


I am using Square Reader iOS SDK in my iOS app. I have started using the app in iOS 15 and I am not able to connect the Square card reader with the iOS device.

Whenever I tried to connect, it gives me the below error:

Reinstallation Required
Please reinstall Point of Sale.

Any idea?

:wave: There is a current issue with Reader SDK and iOS 15. The team is currently working on a fix. In the meantime we don’t recommend updating to iOS 15. I’ll be sure to reach out with any updates. :slightly_smiling_face:

Hi @Bryan-Square Thanks for the quick reply.

@Mauliks If you could update to the latest version of Reader SDK 1.5.2 that should resolve the issue.

Great! Thanks for the info.

Yes, the latest version of SDK fixed the issue.

Also, is there any place where we can check for new updates for SDKs?

Yes, you can check our Release Notes for all the updates for Reader SDK. :slightly_smiling_face:

Unfortunately we’re still seeing this issue after updating to SDK v1.5.2 (under iOS 15).
Resetting the reader does work occasionally when paired with removing our app from the device and a little mystic muttering, though not consistently.

Basically it manifests as starting to connect then failing instantly, or being stuck with a status of “connecting”. In the latter case if you back out of the “Pair your reader” modal we’re presented with a “Device Not Supported” modal.

:wave: What’s your application Id and the location_id that you are trying to pair the reader too? Also we just released 1.5.3. If you could update to that version and try to pair the reader does it work?

Hi @Bryan-Square :wave:

Application ID is sq0idp-GBVzxWpHLUCs0iyVR0qImw ;
Location ID is MT8E4FH8V8VRR

I’ve just updated the framework to 1.5.3 (and great to see - I saw the checkout view controller error when I could get the reader to pair!) - unfortunately it doesn’t seem to fix the pairing issue.

I’m a bit confused with your comment. You mentioned that you got a checkout view controller error when you could get it to pair. Where you able to get it to pair and if you weren’t what troubleshooting steps did you do?

I’ve been able to pair the reader once after resetting the reader, but since then I’ve not been able to.

I assume it was some combination of resetting the reader, removing the entry from the Bluetooth settings and reinstalling the app, though I’ve not been able to get it to pair since.

(@Bryan-Square - sorry - I’ve had to edit this existing post with my reply; As a new user I’m only allowed to reply in a topic 3 times :man_facepalming:)

So after resetting the reader you were able to successfully pair the reader?

Hi @Bryan-Square

I am getting the same error again with iOS 16 Beta. Am I too early to test in iOS Beta?

At this time we don’t support beta iOS 16 Beta. :slightly_smiling_face:

We are also waiting for the ReaderSDK that will work for iOS16. Currently release gives a connection error after pairing. Can not connect to reader error.

RunSignup Inc.

Yes, that is correct. The team is working on iOS 16 support with Reader SDK. I’ll be sure to post any updates. :slightly_smiling_face: