Editing Inventory Stock

Hello, I am working with the Inventory API trying to add stock to an item, however I am having some issues.

When I send a inventory/changes/batch-create request, it appears to send correctly. However, when i go and look at the inventory management page the stock shows up as 0, and the stock inside the item shows up as 1. The stock counter does not increase when I send a new request.

I am going from state NONE to IN_STOCK.
The catalog_object_id is set to the object variation ID
The location_id is set to the sandbox location
The quantity is set to 100 (as a test)
The type is set to ADJUSTMENT

This is all being done in the sandbox development environment.

Hope to hear back soon.

:wave: What’s your application ID that you’re seeing this with? Also would you mind listing the steps to reproduce? :slightly_smiling_face:

Something similar is happening with items in my sandbox as well. If I go to a specific item and change the stock quantity I will see it on the item list screen. However, if I go to a different page, home page for example, and return, the stock is displayed as 0. If I go to the edit screen of a specific item it says stock is being tracked as well as having the number of items previously set. The problem is, is that it doesn’t reflect on the item list nor my app when getting the items.

This is pretty much exactly the problem I am facing.


It looks like the issue has changed slightly since my first post (mind you I have only changed the date time stamp and idempotency key).

When i send a request now it appears to register the inventory change, and properly reflects in the items “edit” tab however it does not display the proper count under the “stock” tab when viewing the item list in the sandbox inventory.

For the ID, is it fine to post here? I assume you are referring to the “Application ID” listed under the credentials tab.

For the new reproducing steps:
1 - Go to POST /v2/inventory/changes/batch-create - Square API Explorer
2 - Fill out the info on the sandbox version
A. Set the quantity above 1
B. Set the type to adjustment
C. Set the to_state to IN-STOCK
3 - Send the request
4 - Go to the sandbox dashboard
5 - Go to the items tab
6 - Observe stock show as 0

As a side not to this question, is it possible to add items via the api without it adding the “drop down”? When you create a item through the dashboard normally and don’t add any variations to it it will just show 1 item and no dropdown, but via the api it appears to always show as a dropdown.

Hope to hear back from you soon!

What are your sandbox merchant_ids? The team has identified an issue and needs them to resolve it. :slightly_smiling_face:

The one which shows up when checking the Request summery in the API logs appears as MLAJ1RPXMD0TX

Thanks for the responsiveness! :blush:

@Jerry Are you still seeing the issue with the sandbox items in the Dashboard? :slightly_smiling_face:

All fixed.

Once again, I appreciate the responsiveness from you in getting this fixed! :heart:

Glad to hear it’s working as expected. :slightly_smiling_face:


The count not showing up under “stock” has started happening again (still in sandbox), I will give it a day or two and see if it decides it wants to work again.

What item in the catalog isn’t showing the inventory correctly? :slightly_smiling_face:

It happens with any item I make through the API, if i set its stock the stock does not show up under the “stock” column but if I go into the item it will show up under the stock option saying “X on hand”.

Okay, I’m checking with the team. :slightly_smiling_face:


Another update for you, the stock is showing up correctly again!

The team is still looking into this. :slightly_smiling_face: