Display on a Square Terminal in Paired mode doesn't sleep

With a Square Terminal in Paired mode, the “Ready to take a payment” screen never sleeps, despite the Display settings set to Turn Off Display after 1 Minute.
I can’t imagine this is by design as it means the display is on 24x7.

Any ideas?

We have this problem also - and if you do sleep the display manually (tapping the power button) it won’t respond to any checkouts being created.

Though now our terminal won’t respond to any checkouts being created regardless of status.

I believe this is a known thing. If the screen goes to sleep, then it could mean that the device wouldn’t be able to receive the push notifications to take a payment. As mentioned above, if you manually turn it off it will most likely stop responding to push notifications. I’ll update this to be a feature request (apologies for the delay!).

Thanks @Stephen.

If a feature request is being logged it would also be great to have a custom logo/background on the “Ready to take a payment” screen just like the POS screen can be branded with a logo/background. Especially if the screen is on 24x7!
Cheers…

1 Like

Reviving this old but still relevant thread…

This does not actually appear to be the case, at least on the current version of the Square Terminal software.

If I manually set the display to be off by pushing the power button briefly, and then sometime later create a terminal checkout, the following happens:

  1. The checkout is created with status “PENDING”.
  2. A very short time later (a second or so) the checkout changes status to “IN_PROGRESS”. The display of the device remains off, but it’s clear that it has started the checkout because:
  3. If I hold a contactless card or device to the display (which is still off), it is read. The checkout status remains “IN_PROGRESS”.
  4. I can now remove the card or device, and wait for a reasonable amount of time (but still remaining within the default 5 minute timeout).
  5. When the display is woken up (power button press or tap on screen) it immediately shows “Authorising” and then processes the transaction, without the card or device being presented again. The checkout status changes to “COMPLETED”.

I think there are two things that need fixing here by the team that maintain the firmware for the Square Terminal:

  1. Stop the “Powered by Square” idle screen preventing the screen from sleeping; it’s not necessary to prevent this, the device is already capable of receiving checkouts with the screen off
  2. When a checkout is received, turn the screen on if it is not already on

There are a couple more things I think would make the idle screen more useful:

  1. (Optionally) Show the device’s DeviceCode.name
  2. Don’t hide the status bar with the wifi signal strength and battery state of charge

And I second the request from @jamesrclay that we be able to add branding to the idle screen!

:wave: @sde1000 I was able to replicate and have shared your findings with the team. :slightly_smiling_face:

I see there’s been a change in the most recent firmware: if the display is off and a checkout is created, the display wakes up and the checkout proceeds immediately. This is very welcome!

I’m reasonably sure the display now goes to sleep on its own while in terminal mode, because I came in after leaving it for the firmware upgrade and found it blank, but I can’t work out how long it takes. I have my terminal set to “Turn Off Display After 1 Minute” in the Display settings, but it’s definitely taking longer than that.

I was wrong. It still doesn’t. The only way to get the display to turn off is to press the power button. After the nightly reboot, the display turns back on and stays on.

This is now my biggest gripe with it! The display being on continuously means the battery doesn’t last very long. If the terminal isn’t plugged in at the end of the day then it doesn’t have enough charge to make it through the night and is completely dead in the morning, which is very inconvenient.

I can understand the desire for the display to be always-on in situations where the terminal is plugged in, but please make this configurable for those of us who use it under battery power!

We’re constantly working to improve our features based on feedback like this, so I’ll be sure to share your request to the API product team. :slightly_smiling_face: