Authorized payment actually succeeded but API returned GENERIC_DECLINE error

Dear team,

We tried to make some authorized payments of $0.01 with payments api (exactly speaking, it’s through java sdk of payments api), in our application (prod env) with a new location,
we noticed all these authorized payments with the new location failed with error GENERIC_DECLINE like below, however we received the SMS saying $0.01 has been charged from the account (of a bank in CN), may i have your advice please whether we missed or mistook anything?

[category=PAYMENT_METHOD_ERROR, code=GENERIC_DECLINE, detail=Authorization error: ‘GENERIC_DECLINE’, field=null]

btw, we also tried to make the same authorized payment with another old location and it was success, the new location is created referring to this old location, except for name different.

What’s you’re location_id? A generic decline will sometimes trigger a pending charge on the customers card. That will fall off once the bank processes the cancelation request we sent to the bank. :slightly_smiling_face:

hi Bryan,

thanks for reply,
the location id is LC4W03NJBWBW5

That will fall off once the bank processes the cancelation request we sent to the bank.

just would like to make it clear, do you mean the cancellation request will be sent automatically by square, or should be sent by us manually through square payment API?

We send the cancelation request immediately. :slightly_smiling_face:

Hi, please solve this issue as i am getting same error if i select a new location to create an order i get same error on payment api. i can send you location id if you want.

thanks for clarifying, that’s safe to our customers :slight_smile:
could you please also help to look into the new location id? as the pending charge has been done (although it’s cancelled as requested), i guess the payment request is acceptable to bank.

@Bryan-Square i tested the same payment again today and it looks the issue still existing, may i have your help please?

What’s the payment_id? :slightly_smiling_face:

sorry we didn’t get payment id, as the payment failed with below error

[category=PAYMENT_METHOD_ERROR, code=GENERIC_DECLINE, detail=Authorization error: ‘GENERIC_DECLINE’, field=null]

we only have the location id LC4W03NJBWBW5

Are you in the US when making these payments? :slightly_smiling_face:

no, i’m in Sweden using an account of chinese bank, when making these payments that failed with location LC4W03NJBWBW5.

however, with the same condition that i’m in Sweden using the same account of chinese bank, the payment can succeed with location id LN1P7NQ0X03TQ, the payment amount is also the same, $0.01.

I just sent a message with additional details on the matter. :slightly_smiling_face:

appreciated your help! let me me check :smiley:

This issue is still not resolved i am still getting GENERIC ERROR but payment is deducted from my account

Are you getting charged the full amount, or is it something like a $0.01 payment? As Bryan said, failed payments may still show a pending charge, but it should be canceled if the payment is declined.

I recommend contacting your bank, as they’ll have more information into what caused a GENERIC_DECLINE :slight_smile: