Adding Square to X-Cart

I have added the app to our x-cart site. I have completed all required information. Whenever we attempt to text the checkout we get an error saying “Unable to load square lib”… I have contacted Square support, X-Cart support and hosting support… no one can answer why we are getting the error. Can we remove the Library? We have a complete website and are only using this as a checkout…Thank you in advance

Is this with a payment link created with CreatePayment link? :slightly_smiling_face:

Hi Bryan… it was on Square’s app site as well as X-Carts add on site.
Square POS & Payments (x-cart.com)

Any help in removing the library or direction would be greatly appreciated… I am about to remove it all together.

The integration is entirely managed by X-Carts. They have access to the code that’s configured to the library’s used to render the Square elements. Do you know what library it’s complaining about? Also is this just happening checkouts you send via text? What are the steps to reproduce? :slightly_smiling_face:

I deleted anything we had in our “library” hoping that would correct the issue. It did not.
If you add anything to the cart… ATV 35" Throttle Cable Chinese Quad 50cc 70cc 90cc 110cc > Throttle Cables > Extreme Motor Sales, Inc and try to checkout… the error appears.

When I inspect the page I don’t see it configured to our JS library web.squarecdn.com/v1/square.js. I’d recommend reaching out to X-Cart with this since there the ones with access to the code. :slightly_smiling_face:

I have tried for 2 days without any help. We are stuck because we cannot process any payments. I have called, emailed and filled out the help desk request. I’m getting desperate because I’m at a standstill and getting all these error processing payments and missing out on sales. It’s frustrating when you know enough… but not enough to help yourself.
Thank you

If you have the support ticket number from X-Cart I recommend reaching out to our Customer Success team. They have an escalation process to get this to X-Cart.

Also did you make any recent changes that would have effected this? :slightly_smiling_face:

I spent all day on the phone with square yesterday

Just to be clear there isn’t anything that we can do on the Square side to resolve this. X-Cart owns and maintains the code. They’re the ones that will need to fix this. If you’ve contacted X-Cart and they said they weren’t able to resolve this you can contact our Customer Success team and provide them with the Support ticket number from X-Cart. It will then be escalated on the Square side to X-Cart. :slightly_smiling_face:

1 Like

Here was xcarts response:

Hello Heidi,

The thing is that Square addon works smoothly with other X-Cart platforms. It means that the issue is specific for your store . We cannot say what the problem is without an investigation. Moreover, you are not hosted with X-Cart, so we cannot be responsible for the hosting environment which also might cause the issue.

The support service with X-Cart is provided on a commercial basis.

Did you get the support ticket number and have you reached out to the Square Customer Success team with it? Also what is your hosting provider? Was there any recent changes that would have caused this issue? :slightly_smiling_face:

Hello
We use TMD hosting… I just installed the square app 3 days ago. We made no changes…I haven’t gotten this to work from the jump. It just keeps saying the lib won’t load.

Yes I did and this was the answer I got:

Although Square integrates with other providers to process payments, the integration is operated and managed by them directly . For help with your website and integration questions and issues, you’ll need to submit a ticket with their Support team.

Their Customer Support team will be able to help you with all Square integration related questions. You’ll want to contact them directly for the best steps to move forward.

So this integration has never worked on your hosted site? Also whats the Square support ticket number. :slightly_smiling_face:

Ticket #865129: Integration of square payments that is x cart
Square just told me to contact you

Do you have another email or phone number that you would recommend?