Access Denied when trying to fetch Catalog Image

When we import catalog items using Catalog API, we fetch the images associated with items as well.

We used to get them in the format like this:

Which is public and accessible to download, but we have recently tried to import an image for one of our sellers that has a different format and it returns an error “Access Denied” when we try to fetch it.

Is there any way we can fix this issue?

That’s weird! Do you mind supplying the catalog item id that this image belongs to? Or even the image id itself, just so I can look it up on our side and see what’s going on. I wasn’t able to find it based on the url or id inside the xml alone :frowning:


Checked in with our catalog team, and at some point in the past we allowed writing the URL, but it never worked correctly. This link will unfortunately never work, and the general suggestion is to replace the image.

Thanks for the update Stepehen. I’ll have our team to disregard if they see images with this issue in the future.