Flutter Square SDK on iOS creates Module 'X' not found error in Xcode


I am currently developing a Flutter app and utilizing the square_reader_sdk package. Once I integrate the square_reader_sdk and follow all of the steps to set it up using this link for iOS: reader-sdk-flutter-plugin/get-started.md at master · square/reader-sdk-flutter-plugin · GitHub, my project in Xcode generates Module ‘X’ not found errors. No matter how hard I try to resolve these errors, they still remain. If I remove the square_reader_sdk package, the module errors go away. The square_reader_sdk version that I am using is on version 3.0.0.

I am developing on a Mac M1 Pro and using Flutter version 3.0.5. I am also running Xcode 13.4.1. I am more than happy to share more information if needed. I believe that I read somewhere that Square still does not support M1 computers. If this is the case or the cause of my issue, when will M1 computers be supported?

Any help to get the iOS build compiling and succeeding would be much appreciated.

Thank you!

:wave: Have you tried to remove the Module and adding them again? :slightly_smiling_face:

Hey Bryan, we have tried removing the modules and adding them again but still no solution. Are there any other suggestions?

What’s the exact error message you’re getting and what’s your application ID. :slightly_smiling_face:

The error message is Module ‘firebase_core’ not found. However, it is indeed within the project. If I remove the ‘firebase_core’ module from the project, it will say the next Module is not found in the list within the GeneratedPluginRestraint.m file. If I remove the Square reader SDK entirely, all of the errors go away. Below is a picture of the error as well. Thank you!

App id is sq0idp-ywhG0XsW6fPiGQTqAVZ1Mg

Hi Bryan,

Any update on this issue?

Are you able to compile our example app? :slightly_smiling_face:

No, same issue on building on a M1 Mac computer. This is the package I am using and it looks like it hasn’t been updated since 13 months ago: square_reader_sdk | Flutter Package. Are there any plans to update the package soon?