Dashboard login page does not remember the password in the browser

Dashboard login page does not remember the password in the browser.
Very inconvenient, but is there nothing I can do about it?

chrome : 97.0.4692.99

:wave: While there isn’t a checkbox for “Remember me” you can have your browser autofill the Dashboard login. :slightly_smiling_face:

That checkbox seems to have disappeared.

It looks like The option to save login details, in any browser, disappeared A couple weeks ago

And the browser(s) ability to propose using
saved login details also went away at the same time

What browser are you using? I’ve been using autofill with Chrome for my account and it works as expected when trying to login. :slightly_smiling_face:

google chrome ver 98.0.4758.102(Official Build)
I’m using this version, and it currently remembers my password.
The behavior seems to have improved.

also here: Chrome seems to work again…

Also Safari works again now

Enable Password Saving for Your Browser

  1. Open the Chrome menu (select icon with three dots at the top right of the window) and select Settings.
  2. Select Autofill on the sidebar. Then, pick the option labeled Passwords to the left side of the Settings screen.
  3. Turn on the switch next to Offer to save passwords.

Steps to get my browser to remember login-
Here’s how to do that:

  1. Open a window or tab in Chrome and click on your profile in the top-right corner of the screen.
  2. Select “Passwords.”
  3. Toggle on the “Offer to save passwords” option.

Regards,
Rachel Gomez