429 error - what is this when I try to make a post?

What is 429 error? I see it when I try to add a new post to an existing thread, or when I try to respond to a message that a Square employee sent to me. I’m able to edit existing posts but I can’t seem to make new posts.

******* 10:46am CST
What retry mechanism? I’m posting to this forum manually. I have no additional security on the browser and I have tried changing to a different browser. Both Chrome and Firefox give the same error.
Trying this post now to see if the error persists.
–It still shows the same 429 error. Can you reach out to your dev team and ask what would cause this error?

******* 10:55am CST
Tried from Safari… same error. I can edit existing posts, and I can create new questions. But I can’t reply to any comment on the question.

I’m not seeing anything that would stop you from posting to an existing post. Do you have any additional security on your browser or have you tried clearing cookies?

Also a 429 error is a rate limit error. Square does have rate limits but we don’t document the limits. We encourage you to handle the limit gracefully by building a retry mechanism. This mechanism should have an exponential backoff schedule to reduce requests when volume is necessary. Also some randomness wouldn’t hurt to avoid a thundering herd effect. :slightly_smiling_face: