403 error on every request on a particular device

We host our API which uses the square payments, devices and terminal API to handle transactions. We’ve had no issues up till now but today started to get 403 forbidden errors on every request. We have tried making the same request on different devices (with the same API token) and it works fine it only on this particular node where we are having issues. We tried reaching out to square support on the phone but were unable to help and said they would email us back. We have some paying customers waiting to make payments and it would be great to get this resolved asap. Is it possible that the IP of the node we are making requests from has been blocked?

Update: it seems we cannot make any requests to square apis from any hetzner node (we have tried the same curl command from a fresh node and are getting the same error)

What’s your IP address and application ID? :slightly_smiling_face:

1 Like

application id:

If you try it now is it working? :slightly_smiling_face:

Hi Bryan,
This does indeed seem to now be working. Can you share what the issue was so that we can understand how this happened?

Thanks for your help!

Glad to hear that this is working as expected. The issue stems from an internal service on our end. The team has deployed a fix to resolve the issue. :slightly_smiling_face:

1 Like

Hi looks like this exact same error has started happening again! This needs to stop happening, we have a show in 2 hours and lots of failing payments coming through! Any chance you can get this fixed soon?

The team has deployed a fix for this. :slightly_smiling_face: