Why does CC form not render when using production square.js?

I’m trying to take an app out of sandbox and into production. I’ve changed my access token, app id, and location id to the production values but when I switch the js from sandbox.web.squarecdn.com/v1/square.js to web.squarecdn.com/v1/square.js the CC form stops rendering. There are no errors in the console and square.js is loaded. What’s wrong here?

Is the page your loading the form on https? :slightly_smiling_face:

Yes, we force https on the site. I ran into that problem on the staging site but it gave me errors so I immediately knew what the problem was and fixed it. I’m getting no errors at all here.

Are there any console errors? Also where is the page hosted so we can inspect? :slightly_smiling_face:

No, no errors in the console. I’ve got the production site disabled while I sort this problem out. Give me a few minutes and I’ll switch the staging site from sandbox to production so you can see the problem there.

And, btw, thank you for responding!

Well, it has magically started working on its own. No idea what was wrong or what changed but I’m glad it’s working now!

Thank you for taking time to help me!

Glad to hear it’s working as expected. :slightly_smiling_face: