OAuth sandbox redirect issue

Hi folks - just wanted to see if anyone else is experiencing an issue when connecting to the https://connect.squareupsandbox.com/oauth2/authorize endpoint. When I submit with my client_id, I receive an error saying that the client_id cannot be found and curiously, the endpoint seems to change to the production version https://connect.squareup.com/oauth2/authorize. Any insight would be greatly appreciated. Thanks community!

Hi @collums welcome to the forums!

Basically, you need to launch your Square sandbox dashboard first for this to work. The error is supposed to tell you how to do this, but currently it’s returning the wrong error, which the team is working on. To launch your sandbox dashboard, please navigate to your apps page: https://developer.squareup.com/apps, and click “Open” next to one of your test accounts. Then, in another tab/window (of the same session), try your authorize endpoint again. Let me know if that still doesn’t work, though!

Thanks (and apologies for the delay!) but that worked a treat. Any idea as to when the messaging will be resolved?

Soon, hopefully :crossed_fingers:. The team is working on it for sure!

Update: this has been fixed now :slight_smile: