MCP Allow Request - Grok

Hi Square team,

Please add Grok (xAI) to the remote MCP client allowlist so sellers can connect Square from grok and console.x.ai.

DCR is failing with invalid_redirect_uri / domain not in allowlist.

Published client identity (please allowlist this): grok.c om/oauth/mcp-client.json

OAuth implementation:

  • OAuth 2.1 with PKCE (RFC 7636)
  • RFC 8414 Authorization Server Metadata
  • RFC 9728 Protected Resource Metadata
  • Public client (token_endpoint_auth_method: none)
  • Grants: authorization_code, refresh_token
  • Response type: code

Redirect URIs:

  • console.x.ai/connectors-oauth-exchange-code/

Domains to allow:

  • grok
  • console.x.ai
  • x.ai

If you support CIMD, accept client_id equal to that grok oauth mcp-client.json URL above.

Happy to send anything else you need.

I’m unable to confirm any of the redirect URIs in xAI documentation, but will add grok.com and console.x.ai to the allowlist. Please allow a few days for this to propagate and check in late this/early next week if it is still not working.

The allowlist has been updated and should be deployed within the next 24h.